SalemNews.com, Salem, MA

Local News

August 17, 2013

Jeep's engine keeps pinging on the highway

Q: I have a 2002 Jeep Grand Cherokee with a 4.7-liter, eight-cylinder engine and 69,000 miles on the odometer. At speeds above 70 miles per hour under load, the engine starts pinging. For most local driving it is not a problem, but on the highway it is very annoying. I have tried higher octane fuel, but that didn’t fix the problem. I have just had the Jeep serviced, cleaning fuel injectors, throttle body, intake valves and ports, which also removes combustion chamber deposits, thinking that might fix the problem. It didn’t. What do you suggest for the next attempt to solve this problem?

A: What has to be done is a road test with diagnostic recording gear connected. When the pinging begins on the car, the technician only has to hit the record button on the diagnostic tool. After the tech gets back from the road test, he can review the recording frame by frame and find the root cause of the problem. The tech will be looking at items like fuel pressure, map sensor readings, timing advance, EGR percentage and knock sensor action. Another very important reading is going to be short-term and long-term fuel trim, as well as the oxygen sensor readings. A trained technician will need a few hours to perform these tests, but your results will be accurate. I do find it curious that you never mentioned a check-engine light being on. The Jeep computer should have picked up the malfunction if the knock sensor is not working. Just so you know, you have a very popular Jeep, and it is capable of giving you 200,000 miles. I am sure you know the pinging is harming your engine. Therefore, I encourage you to stay with the pursuit of having this problem professionally repaired.

Q: My 1998 two-door, sport, eight-cylinder automatic Vortec engine with 87,500 miles has been giving me an intermittent starting problem. On the initial start-up of the day it behaves as though it has a dead battery; solenoid clicking but no cranking. Starts right up with a jump from another vehicle and starts fine for the rest of the day. I really don’t drive very much, so I don’t start it very often to confirm that it’s only the initial start-up, but that’s how it appears. The battery and starter are new, and the alternator tests OK (approximately 3 years old). I’m stymied as to what could be the problem and pray that you can help!

Text Only | Photo Reprints
Local News

AP Video
Bon Jovi Helps Open Low-income Housing in Philly Pipeline Opponents Protest on National Mall Hagel Gets Preview of New High-tech Projects S.C. Man Apologizes for Naked Walk in Wal-Mart New Country Music Hall of Fame Inductees Named 'Piles' of Bodies in South Sudan Slaughter New Yorkers Celebrate Cherry Blossom Blooms SCOTUS Hears Tv-over-Internet Case Justice Dept. Broadening Criteria for Clemency Chief Mate: Crew Told to Escape After Passengers 'Miss Meadows' Takes Holmes Back to Her Roots Biden: Russia Must Stop Talking, Start Acting David Moyes Out As Manchester United Manager Raw: Leopard Bites Man in India Iowa College Finds Beauty in Bulldogs High Court to Hear Dispute of TV Over Internet Stowaway Teen Forces Review of Airport Security
Comments Tracker